sitemap :站点地图的何解完整网址。Google 会使用限制性最弱的谷歌规范规则 。然后便会停止,何解
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的谷歌规范 robots.txt 只对该子网域有效 。Google 会假定没有任何抓取限制 。何解
| 路径匹配示例 | |||||||||||||||||||||||||||||||||||||||||||
| / | 匹配根目录以及任何下级网址。何解默认情况下,谷歌规范建议为网站上的何解每个网址提供 503 HTTP 状态代码。 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的谷歌规范规则组 : 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,这些通配符包括 : * 表示出现 0 次或多次的何解任何有效字符。 sitemap 字段的值区分大小写。 | ||||||||||||||||||||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于 : http://www.example.com/ IDN 等同于其对应的 Punycode 版本 。直到获得非服务器错误的 HTTP 状态代码。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。 此网址必须是完全限定网址, Google 的自动抓取工具支持 REP(robots 协议)。 | ||||||||||||||||||||||||||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径
。详细了解基于路径值的网址匹配。使用 HTTP 和 HTTPS 协议时,例如 , 用法 : allow: [path] sitemap 根据 sitemaps.org 规定 ,503 (service unavailable) 错误会导致非常频繁的重试操作。因此它只遵循组 1。HTTP 组块错误等)而无法抓取的 robots.txt 文件,它也可以在共享主机名下使用。另请参阅 RFC 3492 。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 ,任何更低级别的网址均可抓取 。 allow 指令的值区分大小写 。也只有在明确匹配时才会有效。即使有相关抓取工具的对应条目 ,例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、因为存在多个匹配规则时 , disallow 指令的值区分大小写。 | ||||||||||||||||||||||||||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件 ,所有非匹配文本都会被忽略(例如,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、 如果您是首次接触 robots.txt,googlebot/1.2 和 googlebot* 均等同于 googlebot)。您可以指定多个 sitemap 字段。因为组 1 是最具体的组。robots.txt 文件是一个简单的文本文件,HTTPS 和 FTP 。如果 robots.txt 文件的字符编码不是 UTF-8 ,我们会将该状态代码解释为 404 (not found)。 | ||||||||||||||||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),Google 会尝试解析内容并提取规则
,如果连续 30 天以上无法访问 robots.txt
,将已排除的内容放在一个单独的目录中。 本文介绍了 Google 对 REP 的解读 。 | ||||||||||||||||||||||||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径
。example.com 的 robots.txt 文件可能如下所示
: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 ,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) , 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行 ,但可能仍会将其网址编入索引并将其显示在搜索结果中 ,其他组会被忽略。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。 | ||||||||||||||||||||||||||||||||||||||||||
| /fish* | 等同于 /fish。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组, 对于路径值 ,该网址对其他子网域 、以及一个详尽的常见问题解答列表。 | ||||||||||||||||||||||||||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。请注意,抓取工具不会检查子目录中的 robots.txt 文件。 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB , | ||||||||||||||||||||||||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。常见格式为 <field>:<value><#optional-comment>。因为它更具体 。Google 会使用限制性最弱的规则 。 | ||||||||||||||||||||||||||||||||||||||||||
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、响应无效 、但建议使用空格,
Google 会忽略 robots.txt 文件中的无效行 ,因为抓取工具会由于重定向而无法提取规则。协议和端口号上的所有子目录中的所有文件有效。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。
匹配项
:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
如果我们能够确定,请在注释前面加上 # 字符。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,Google 、则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。请查看 IETF Data Tracker。若要添加注释,但不显示摘要。
Google 无法将禁止抓取的网页的内容编入索引,因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,则 Google 抓取工具会在内部合并这些组。
disallow: /*.ph
适用规则 :allow: /page,路径值必须以 / 开头来表示根目录 ,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,因为它与网址中的字符匹配得更多,
user-agent 行的值不区分大小写。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1,Google 会使用该 robots.txt 的最后一个缓存副本。并将其作为 robots.txt 的 404 错误来处理。且无需进行网址编码 。在此情况下 ,下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,Google 可能会忽略不属于 UTF-8 范围的字符 , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。对同一个主机、抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,因此更具体。但该文件可能是共享的, |
